Sabtu, 10 Oktober 2009

PENGERTIAN DAN SEJARAH TENTANG IPX/SPX



Sebuah teknologi jaringan yang hanya mendukung hingga 254 node untuk tiap jaringan fisiknya, dan dapat berjalan di atas protokol LocalTalk, sebuah antarmuka serial RS-499 / RS-422 yang terdapat di dalam komputer Apple Macintosh. Pada versi AppleTalk Phase II yang lebih baru, protokol yang didukung semakin luas, yakni EtherTalk (untuk konektivitas dengan Ethernet), TokenTalk (untuk konektivitas dengan Token Ring), dan FDDITalk (untuk konektivitas dengan FDDI). Macam AppleTalk antara lain:AppleTalk Data Stream ProtocolAppleTalk File Protokol (AFP)Sebuah protokol layer presentation, mendukung file sharing AplleShare dan Mac OS, mengizinkan user melakukan sharing file dan aplikasi pada sebuah server.AppleTalk Session Protocol (ASP)Protokol yang menggunakan ATP untuk menetapkan, memelihara, dan memutuskan session-session, dan juga permintaan-permintaan yang berurut.AppleTalk Transaction Protocol (ATP)AppleTalk Control Program (ATCP)Protokol untuk menetapkan dan mengkonfigurasi AppleTalk di atas PPP, didefinisikan dalam RFC 1378.AppleTalk Address Resolution Protokol (AARP)Kumpulan protokol AppleTalk yang memetakan alamat data-link alamat network (pengalamatan dinamis). Maksudnya, Alamat mesin di dalam jaringan berbasis AppleTalk secara acak akan diberikan ketika mesin tersebut dikoneksikan ke jaringan tersebut, dan mesin tersebut akan membuat sebuah paket yang dikirimkan secara broadcast untuk menjamin bahwa tidak ada mesin lainnya yang menggunakan alamat tersebut.AARP Probe PacketsPaket-paket yang dikirim oleh AARP untuk menentukan apakah sebuah node ID (identifikasi dari sebuah titik / node) yang diberikan sedang digunakan oleh node lain pada sebuah network AppleTalk yang nonextended. Jika node ID tidak sedang digunakan oleh node lain, node pengirim akan memilih node ID tersebut. Jika node ID sedang digunakan oleh node lain, node pengirim akan memilih sebuah ID lain dan kemudian mengirimkan keluar AARP probe packets yang lebih banyak.AppleTalk Echo Protokol (AEP)Sebuah tes untuk koneksivitas antara dua node atau terminal appletalk di mana satu terminal mengirimkan paket ke terminal lain dan menerima sebuah echo atau copy sebagai tanggapan.AppleTalk Update-based Routing Protokol. (AURP)Sebuah teknik untuk mengenkapsulasi lalu lintas ApplTalk dalam header dari sebuah protocol asing yang memungkinkan koneksi dari paling sedikit dua internetwork ApplteTalk yang tidak bersambungan melalui sebuah network asing (seperti TCP/IP) untuk menciptakan sebuah WAN AppleTalk yang lengkap.AURP TunnelSebuah koneksi dibuat di sebuah WAN AURP yang bertindak sebagai sebuah link virtual tunggal antara internetwork AplleTalk yang terpisah secara fisik oleh sebuah network asing seperti network TCP/IP.IPX / SPXJenis protokol komunikasi yang dipakai oleh komputer-komputer untuk berkomunikasi satu sama lain pada suatu jaringan. IPX digunakan oleh Novell untuk mengantarkan data antara pelayan dan pelanggan. SPX digunakan untuk menjamin pengantaran pesan pada lapisan pengangkutan.IPX / SPX ditemukan oleh Novell dan umumnya hanya dipakai pada jaringan model kuno atau jaringan yang memakai software Novell NetWare. Kebanyakan jaringan saat ini menyukai TCP/IP ketimbang SPX/IPX, karena TCP/IP adalah protokol yang dipakai di Internet. Protokol ini adalah protokol yang routable sama seperti Appletalk, TCP/IP, DECNet dan XNS. Didalam Windows NT keduanya dikenali sebagai NWLink. IPX berfungsi pada Network layer dan SPX berfungsi pada Transport layer.

PENGERTIAN DAN SEJARAH NETBEUI

NetBEUI singkatan dari istilah dalam bahasa Inggris: NetBIOS Extended User Interface, adalah sebuah protokol jaringan yang dikembangkan oleh International Business Machine Corporation (IBM) dan Microsoft Corporation pada tahun 1985 yang digunakan untuk jaringan lokal (LAN) yang terdiri atas komputer hingga 200 stasiun kerja. NetBEUI sendiri adalah ekstensi dari protokol NetBIOS.
NetBEUI merupakan protokol utama yang digunakan dalam LAN Manager dan Windows for Workgroups. Protokol ini juga cukup gegas dan efisien. Protokol ini mendukung komunikasi dengan cara connection-oriented (seperti halnya melakukan pemetaan drive di jaringan) atau connectionless (seperti halnya melakukan registrasi nama NetBIOS atau resolusi nama NetBIOS). NetBEUI juga mengimplementasikan fitur flow control dan pendeteksian kesalahan. NetBEUI mendefinisikan mekanisme pembuatan frame pada lapisan transport dan juga mengimplementasikan protokol Logical Link Control 2 dalam model referensi tujuh lapis OSI.
NetBEUI didukung sepenuhnya oleh semua sistem operasi Microsoft Windows. Implementasi NetBEUI dalam sistem operasi Windows NT disebut dengan NetBEUI Frame Protocol.
NetBEUI Frame Protocol
NetBEUI Frame Protocol adalah implementasi lebih lanjut dari protokol jaringan NetBEUI yang hanya tersedia dalam sistem operasi Windows NT. Beberapa perbaikan dan fitur-fitur yang dimiliki oleh protokol ini adalah sebagai berikut:
•Mendukung spesifikasi NDIS (Network Driver Interface Specification) versi 3 untuk komunikasi lapis transport 32-bit secara asinkron dengan menggunakan lapisan TDI (Transport Driver Interface) sebagai emulator NetBIOS.
•Peningkatan kinerja dengan cara melakukan alokasi memori secara dinamis.
•Dukungan terhadap klien-klien yang menggunakan koneksi dial-up dengan menggunakan layanan Remote Access Service (RAS).
•Perubahan pada limitasi jumlah sesi NetBEUI dari 256 sesi NetBEUI menjadi lebih dari 1000 sesi NetBEUI.

PENGERTIAN DAN SEJARAH TCP/IP



Apa itu TCP/IP ?

* TCP/IP adalah salah satu jenis protokol* yg memungkinkan kumpulan komputer untuk berkomunikasi dan bertukar data didalam suatu network (jaringan).

* Merupakan himpunan aturan yg memungkinkan komputer untuk berhubungan antara satu dengan yg lain, biasanya berupa bentuk / waktu / barisan /pemeriksaan error saat transmisi data.

Apa yg membuat TCP/IP menjadi penting ?

* Karena TCP/IP merupakan protokol yg telah diterapkan pada hampir semua perangkat keras dan sistem operasi. Tidak ada rangkaian protokol lain yg tersedia padasemua sistem berikut ini :


a. Novel Netware.

b. Mainframe IBM.

c. Sistem digital VMS.

d. Server Microsoft Windows NT

e. Workstation UNIX, LinuX, FreeBSD

f. Personal komputer DOS.

Bagaimana awalnya keberadaan TCP/IP ?

* Konsep TCP/IP berawal dari kebutuhan DoD (Departement of Defense) AS akan suatu komunikasi di antara berbagai variasi komputer yg telah ada. Komputer-komputer DoD ini seringkali harus berhubungan antara satu organisasi peneliti dg organisasi peneliti lainnya, dan harus tetap berhubungan sehingga pertahanan negara tetap berjalan selama terjadi bencana, seperti ledakan nuklir. Oleh karenanya pada tahun 1969 dimulailah penelitian terhadap serangkaian protokol TCP/IP. Di antara tujuan-tujuan penelitian ini adalah sebagai berikut :

1. Terciptanya protokol-protokol umum, DoD memerlukan suatu protokol yg dapat
ditentukan untuk semua jaringan.

2. Meningkatkan efisiensi komunikasi data.

3. Dapat dipadukan dengan teknologi WAN (Wide Area Network) yg telah ada.

4. Mudah dikonfigurasikan.

Tahun 1968 DoD ARPAnet (Advanced Reseach Project Agency) memulai penelitian yg kemudian menjadi cikal bakal packet switching .Packet switching inilah yg memungkinkan komunikasi antara lapisan network (dibahas nanti) dimana data dijalankan dan disalurkan melalui jaringan dalam bentuk unit-unit kecil yg disebut packet*. Tiap-tiap packet ini membawa informasi alamatnya masing-masing yg ditangani dengan khusus oleh jaringan tersebut dan tidak tergantung dengan paket-paket lain. Jaringan yg dikembangkan ini, yg menggunakan ARPAnet sebagai tulang punggungnya, menjadi terkenal sebagai internet.

Protokol-protokol TCP/IP dikembangkan lebih lanjut pada awal 1980 dan menjadi protokol-protokol standar untuk ARPAnet pada tahun 1983. Protokol-protokol ini mengalami peningkatan popularitas di komunitas pemakai ketika TCP/IP digabungkan menjadi versi 4.2 dari BSD (Berkeley Standard Distribution) UNIX. Versi ini digunakan secara luas pada institusi penelitian dan pendidikan dan digunakan sebagai dasar dari beberapa penerapan UNIX komersial, termasuk SunOS dari Sun dan Ultrix dari Digital. Karena BSD UNIX mendirikan hubungan antara TCP/IP dan sistem operasi UNIX, banyak implementasi UNIX sekarang menggabungkan TCP/IP. unit informasi yg mana jaringan berkomunikasi. Tiap-tiap paket berisi identitas (header) station pengirim dan penerima, informasi error-control, permintaan suatu layanan dalam lapisan network, informasi bagaimana menangani permintaan dan sembarang data penting yg harus ditransfer.

Layanan apa saja yg diberikan oleh TCP/IP

Berikut ini adalah layanan "Tradisional" yg dilakukan TCP/IP :

* Pengiriman file (file transfer). File Transfer Protokol (FTP) memungkinkan pengguna komputer yg satu untuk dapat mengirim ataupun menerima file ke komputer jaringan. Karena masalah keamanan data, maka FTP seringkali memerlukan nama pengguna (username) dan password, meskipun banyak juga FTP yg dapat diakses melalui anonymous, lias tidak berpassword. (lihat RFC 959 untuk spesifikasi FTP)

* Remote login. Network terminal Protokol (telnet) memungkinkan pengguna komputer dapat melakukan log in ke dalam suatu komputer didalam suatu jaringan. Jadi hal ini berarti bahwa pengguna menggunakan komputernya sebagai perpanjangan tangan dari komputer jaringan tersebut.( lihat RFC 854 dan 855 untuk spesifikasi telnet lebih lanjut)

* Computer mail. Digunakan untuk menerapkan sistem elektronik mail.


* Network File System (NFS). Pelayanan akses file-file jarak jauh yg memungkinkan klien-klien untuk mengakses file-file pada komputer jaringan jarak jauh walaupun file tersebut disimpan secara lokal. (lihat RFC 1001 dan 1002 untuk keterangan lebih lanjut)

* remote execution. Memungkinkan pengguna komputer untuk menjalankan suatu program didalam komputer yg berbeda. Biasanya berguna jika pengguna menggunakan komputer yg terbatas, sedangkan ia memerlukan sumber yg banyak dalam suatu system komputer. Ada beberapa jenis remote execution, ada yg berupa perintah-perintah dasar saja, yaitu yg dapat dijalankan dalam system komputer yg sama dan ada pula yg menggunakan "prosedure remote call system", yg memungkinkan program untuk memanggil subroutine yg akan dijalankan di system komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah "rsh" dan "rexec")

* name servers. Nama database alamat yg digunakan pada internet (lihat RFC 822 dan 823 yg menjelaskan mengenai penggunaan protokol name server yg bertujuan untuk menentukan nama host di internet.)

RFC (Request For Comments) adalah merupakan standar yg digunakan dalam internet,

meskipun ada juga isinya yg merupakan bahan diskusi ataupun omong kosong belaka.

Diterbitkan oleh IAB (Internet Activities Board) yg merupakan komite independen

para peneliti dan profesional yg mengerti teknis, kondisi dan evolusi sistem

internet. Sebuah surat yg mengikuti nomor RFC menunjukan status RFC :

S : standard, standar resmi bagi internet

DS : Draft standard, protokol tahap akhir sebelum disetujui sebagai standar

PS : Proposed Standard, protokol pertimbangan untuk standar masa depan

I : Informational, berisikan bahan-bahan diskusi yg sifatnya informasi

E : Experimental, protokol dalam tahap percobaan tetapi bukan pada jalur standar.

H : Historic, protokol-protokol yg telah digantikan atau tidak lagi dipertimbangkan utk standarisasi.